Subject: su gives "Unmatched `. "
To: None <>
From: Siju George <>
List: netbsd-users
Date: 04/05/2007 16:58:43

I am new to NetBSD.
Have installed it once or twice before and not used it actually.
I  have been using OpenBSD and FreeBSD for a few years now.
I want to migrate my Samba Domain Controller from FreeBSD 6.1  to
NetBSD 3.1 so I installed it and just tried to get familiar with it.

I just found some thing strange and wouls like to hear what it is from
some one who knows :-)

vtcdc: {12} visudo
visudo: Command not found.

vtcdc: {11} su
su: Sorry: authentication error

vtcdc: {15} su
'vtcdc: {1} whoami
Unmatched '.

vtcdc: {2} exit
vtcdc: {3} exit
vtcdc: {16} su
vtcdc: {2} whoami
vtcdc: {3}


In the First two lines I tried to Configure sudo ( as is my practice
in OpenBSD ) but found visudo is missing. hope i wil have to install
it through pkgsrc right?

In the Second paragraph I mistyped the the root password and it gave
the error "Sorry: authentication error"

I think I typed or mistyped the password again

see the prompt starts with a '

'vtcdc: {1} whoami
Unmatched '.

what happened here really?

Thankyou so much :-)

Kind Regards