Subject: Re: packages after updating and COMPAT_*
To: Greg Troxel <>
From: Thierry Lacoste <>
List: netbsd-users
Date: 04/03/2007 20:27:02
On Sunday 01 April 2007 01:49, Greg Troxel wrote:
> If you do decide to start rebuilding, then you should rebuild
> everything.  Sometimes major numbers of libraries change (libz,
> libcrypto), and if you have some libraries in pkgsrc linked against
> some and some against others there could be trouble.  Surprisingly
> though, it often works -- but you're on thin ice.

One more question.
When moving among the 3* versions (e.g. upgrading from 3.0 to 3.1)
is there any benefit to rebuild packages?