Subject: Re: newfs problem on raid device
To: None <>
From: Christoph Kaegi <>
List: netbsd-users
Date: 11/13/2006 11:21:28
On 10.11-17:00, Christoph Kaegi wrote:
> I'm setting up a NetBSD 3.1 system with two identical disks that
> should be mirrored.
> I have labeled the raid0 device as usual, like this:
>  a:   2098059         0     4.2BSD   1024  8192 45616  # (Cyl.      0 -   2048*)
> Now, when I try to newfs this slice, it says:
>  wtfs: write error for sector 16: Read-only filesystem
> I tried to let the filesystem start at sector 63. That worked
> for the newfs part, but then the computer didn't boot anymore,
> saying:
>   Boot failed (errno 2): Can't open /boot.
> So i guess I have to solve the former problem first: why 
> can't I newfs the raid0a slice?
> The disk is a Seagate ST336607LC. Someone on the mailing list
> had a similar problem and had to add it to a quirk table. Does 
> that ring a bell for someone?

I didn't find out, what the problem really was. But I salvaged
the system by 

- deactivating raid partitions and cleaning boot area (with dd)
  on sd0
- installing NetBSD again to sd0
- rebuilding raid0 on sd1 and migrating / fs vom sd0 to raid0
- activating the raid partitions and booting off them
- labling sd0 like sd1 and pulling the sd0 slices as spares 
  into mirror

This time, everything worked.
Thanks for your help.


Christoph Kaegi