Subject: Re: newfs problem on raid device
To: None <>
From: Christoph Kaegi <>
List: netbsd-users
Date: 11/13/2006 08:03:35
On 10.11-20:21, Stephen Borrill wrote:
> >I tried to let the filesystem start at sector 63. That worked
> >for the newfs part, but then the computer didn't boot anymore,
> >saying:
> >
> > Boot failed (errno 2): Can't open /boot.
> Silly question, but did you have /boot on partition a?

It should certainly have had it, because it booted ok before it was 
mirrored. But I can't verify that anymore.

I booted from the install CD and used the shell to fsck and mount
raid0a. fsck said something about fixing the main superblock and
then the filesystem was empty... ?

> >The disk is a Seagate ST336607LC. Someone on the mailing list
> >had a similar problem and had to add it to a quirk table. Does
> >that ring a bell for someone?
> Yes, there are Seagate probs, but they affect high offsets on the disk. 
> This drive already has a quirk (it's caught by the catch all expression).
> This partition is only 2048 cylinders, so you aren't hitting any such 
> problems.



Christoph Kaegi