Subject: Re: newfs problem on raid device
To: Christoph Kaegi <>
From: Stephen Borrill <>
List: netbsd-users
Date: 11/10/2006 20:21:42
On Fri, 10 Nov 2006, Christoph Kaegi wrote:
> I'm setting up a NetBSD 3.1 system with two identical disks that
> should be mirrored.
> I have labeled the raid0 device as usual, like this:
> a:   2098059         0     4.2BSD   1024  8192 45616  # (Cyl.      0 -   2048*)
> Now, when I try to newfs this slice, it says:
> wtfs: write error for sector 16: Read-only filesystem

Yes, I see that pretty much every time I have a partition with offset 0. I 
find fsck -y on the partition finds an alternate superblock and then it 

> I tried to let the filesystem start at sector 63. That worked
> for the newfs part, but then the computer didn't boot anymore,
> saying:
>  Boot failed (errno 2): Can't open /boot.

Silly question, but did you have /boot on partition a?

> The disk is a Seagate ST336607LC. Someone on the mailing list
> had a similar problem and had to add it to a quirk table. Does
> that ring a bell for someone?

Yes, there are Seagate probs, but they affect high offsets on the disk. 
This drive already has a quirk (it's caught by the catch all expression).
This partition is only 2048 cylinders, so you aren't hitting any such