Subject: Re: Quota, Softdeps, and Raid - and the Quality of NetBSD Releases
To: None <>
From: Lasse Kliemann <>
List: netbsd-users
Date: 09/14/2006 22:57:57
* Manuel Bouyer:::
> On Thu, Sep 14, 2006 at 03:00:43PM +0200, Lasse Kliemann wrote:
> > > This is a symptom of some other bug in the kernel, one I have been
> > > trying to find for months with only limited success.
> > > 
> > > Is your system, by any chance, an amd64 machine running a 32-bit (i386)
> > > kernel?
> > 
> > Yes! From dmesg:
> > 
> > cpu0 at mainbus0: (uniprocessor)
> > cpu0: AMD Unknown K7 (Athlon) (686-class), 1799.90 MHz, id 0x10ff0
> > cpu0: features 78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR>
> > cpu0: features 78bfbff<PGE,MCA,CMOV,PAT,PSE36,MPC,MMX>
> > cpu0: features 78bfbff<FXSR,SSE,SSE2>
> > cpu0: "AMD Athlon(tm) 64 Processor 3000+"
> > 
> > I am using NetBSD/i386.
> > 
> > 
> > I get a similar error even when sofdeps are off, but quotas 
> > are on. It seems to be nearly reproduceable, I just have to 
> > unpack a large tar file.
> > 
> > 
> > Maybe we can solve this thing?
> Well, it seems to be related to amd hardware, and as it's memory corruption
> it's quite hard to find. For the record, I run some heavily loaded servers
> (NFS/samba servers, mail servers) with quota (but without softdep) on
> Intel hardware and never got such a panic.

As Thor suggested to me, I installed an amd64 system on the 
machine tonight. The problem still exists. I have only tried 
sofdeps plus quota. When I unpack a large tarfile, after a 
while the machine reboots. I can see for some seconds a 
green message with something that has 'fault trap' in it.

So maybe we should note somewhere that using NetBSD on certain 
AMD hardware is not a good idea in the moment, so that other 
users are warned? As you said, this will be hard to find, and 
so the problem is not likely to go away soon. Or is it not a 
problem of NetBSD, and every OS will experience memory 
corruption on such a machine? (I'm sorry if this is a silly 

All the Best,