Subject: Re: newbee questions on fdisk/boot
To: J.D. Bronson <>
From: haad <>
List: netbsd-users
Date: 09/14/2006 15:44:39
Hash: SHA1

Sometime ago I have similar error and I have to run:

cp /usr/mdec/boot /boot
to resolve this problem.

see more in installboot(8)
at the end of man page there are examples ,see amd64 & i386 example for more.

- ---------------------------------------------------------------
Adam Hamsik
ICQ 249727910
- ---------------------------------------------------------------
There are 10 kinds of people in the world. Those who understand
binary numbers, and those who don't.

J.D. Bronson wrote:
> I know I posted a similar question here last month but I am still
> missing something and need some assistance (please)...
> I have a complete 3.0.1 install and its working fine (i386). No issues!
> This install is 100% netbsd. It does not share any fdisk or boot with
> any other OS. Just Netbsd.
> I have a larger hard drive (current 60gb - new 120GB) and want to
> *simply* migrate over to the new drive. I have done this under freebsd
> and openbsd and never had any issues. However under netbsd, I end up
> with constant boot issues...
> I am very surprised that there does not appear a section on the netbsd
> pages outlining steps on how to do this? I am sure I am not the 1st
> idiot to attempt this and have issues...
> I will list what I am doing and perhaps someone here can spot what I am
> missing or why things are not working:
> 1. fdisk -u wd2 -> create partition 1 for netbsd.
> 2. fdisk -a wd2 -> make partition 1 the active partition
> 3. disklabel wd2 -> slice and dice drive up
> 4. newfs each partition
> 5. mount each partition such as /mnta /mnte/ /mntf and so on
> 6. dump -0f - / | ( cd /mnta ; restore xf - ) for each partition
> 7. verify each old slice matches the new slice via rsync.
> 8. umount all of the temp mount points
> 9. run installboot such as:
> installboot -v -o timeout=5 /dev/rwd1d /usr/mdec/bootxx_ffsv1
> (I also tried this to no avail):
> installboot -v -o timeout=5 /dev/rwd1a /usr/mdec/bootxx_ffsv1
> Then shut down. Attempt to boot off of the new drive.
> I get an error message saying it cant find '/boot'.
> I then tried using fdisk to setup a bootselector with a time out of 5
> seconds and that allowed me to finally boot. But it gave a prompt while
> the 5 seconds was timing out...and the original disk does not have
> anything like this.
> Does anyone have any idea what I am still missing?
> Failing this, my next idea was to do a small install on the new drive to
> set things up and then rsync my original install to the new drive, but
> that shouldnt need to be done...
> Thanks in advance for any pointers.
> -- 
> J.D. Bronson
> Telecommunications Site Support
> Aurora West Allis Memorial Hospital
> Office: 414.978.8282 Fax: 414.977.5299
> "Never trust a man who doesn't drink" - WC Fields
Version: GnuPG v1.4.4 (NetBSD)
Comment: Using GnuPG with Mozilla -