Subject: Re: "New" NetBSD MBR boot documentation and recovery?
To: None <>
From: None <>
List: netbsd-users
Date: 09/08/2006 07:28:11
I do not get a countdown timer at all.

I just used the recent 3.0.1 release CD and did a more or less
default install.

To be clear, this system worked fine in the base configuration.

I actually took it all the way up to -current and then back
to -netbsd4 with no difficulty.

Only when I tried to optimize the kernel did I get a problem.

There is no counter that's the old bootloader.

Now all I get is:
  NetBSD MBR boot

  NetBSD/i386 ffsv1 Primary Bootstrap

That's it. This is what the 3.0.1 installer put in place by default.
This is what I am asking about.

> On Fri, 2006-09-08 at 06:14 -0500, wrote:
>> Hi All,
>> I've been using NetBSD since at least the 1.5xx series and still use
>> the old boot loader which was common to my Mac68k and my i386
>> household router/firewall/gateway boxen.
>> Recently I started using vmware virtual machines to play with
>> fresh releases and cvs in a way that did not threaten the "production"
>> server...
>> Anyway, this is note is *not* urgent because it's just
>> on a test virtual machine, but someday I may update the boot loader
>> on my production box. Also, soon many more of the current user base will
>> be moving to the new MBR boot loader and may have these issues.
>> Apologies if it's already documented somewhere...I did google the site
>> and took a quick look at the NetBSD guide, which appears to still
>> be written for the old boot loader. I looked for "mbr boot" and found
>> nothing.
>> My that I've rambled on...
>> #1 If you have an unsuccessful kernel build and want to get back to
>>    the previous kernel in /netbsd.old ...
>>    HOW do I do it with the new MBR boot?
>> #2 Is there some magic key sequence?
>> #3 Also, is there some way to get the new booter to display the kernel
>>    startup messages like the old booter did?
>> Thanks,
>> gene
> Hi
> To get the bootloader to boot another kernel press the spacebar when the
> countdown sequence starts and type
> 	boot hd0a:netbsd.old
> at the prompt, hd0a being the hard drive number and partition where the
> kernel image is. Type help or ? at the prompt for commands too.
> If you only get "NetBSD/arch ustarfs Primary Bootstrap" then you're
> probably using the wrong floppy image. I use the boot-com1.fs and
> boot-com2.fs disks so I get the install on my Wyse terminal which runs
> off a serial port. There's information in the bootloader help to deal
> with changing the default console too.
> Have a look at installboot(8), it has details on installing a new
> bootloader with examples including dealing with the default console.
> Good Luck.