Subject: Re: Problem with eggdrop on sparc64
To: None <>
From: Christos Zoulas <>
List: netbsd-users
Date: 02/08/2006 18:05:44
In article <dscevk$s5$>, kubele  <> wrote:
>hi paolo, try run eggdrop without loading module dns,
>find and comment 'loadmodule dns' in your eggdrop configuration file.
>Paolo Gatti wrote:
>> Hello, I have a problem with eggdrop on sparc64 (I have installed it
>> from the pkgsrc): when I run it, with the command:
>> one@sun:~/eggdrop> ./eggdrop -m eggdrop.conf
>> Eggdrop v1.6.17 (C) 1997 Robey Pointer (C) 2004 Eggheads
>> [00:59] --- Loading eggdrop v1.6.17 (Wed Feb  8 2006)
>> [00:59] Listening at telnet port 41447 (all).
>> _res is not supported for multi-threaded programs.
>> ... consequence, eggdrop in core . I have tried with the pkg, too, but I
>> have the same problem. Can you help me please?

eggdrop should be fixed to use the re-entrant dns routines. You are
not allowed to use _res directly on NetBSD if you are using threaded
code, because it is non-portable.