Subject: Booting net NetBSD 2.1 Install gives "Error 3" error.
To: None <>
From: None <>
List: netbsd-users
Date: 12/09/2005 19:51:19
Hi All,

	I am having difficulty with running a newly installed NetBSD system. I have in the past installed NetBSD on a few systems so I am vaguely familiar with the task, but i have come across some problems during this install. Basically i can install the system (With some small issues with the CD ROM which are mentioned below), but it will not boot into NetBSD. It fails with the error description: "Error 3". I have listed below steps i have performed and things i have tried to get NetBSD to boot. If someone could point me in the correct direction to get this NetBSD install working correctly i would greatly appreciate it.


Processor: Celeron 633
RAM: 224Mb
Hard Drive: Segate Barracuda 40GB (ST340016A)
NetBSD: 2.1 (A bootable CD i compiled on a different NetBSD system and have used in the past for installing on other PC's)

The Install CD boots fine and I can install the system via FTP from another machine on the local network. Though there was a problem trying to install from the CD itself. Described below, but this is not the main problem.

(Problem installing from CD ROM)
I was having difficulty installing the sets from the cdrom drive /dev/cd0a It could not be mounted, so I tried installing using FTP instead. Upon trying to mount the cdrom I get the following error:

cd0(viaide0:1:0): not ready = 00 00 00 00 3a 00 00 00 00 00 00 00 00 03
Mount: cannot open ~Q/dev/cd0a~R

However when starting up the NetBSD installer I see that it recognises my CD drive fine (Fast to see just before the installation menu pops up, but it does find it).

The installation goes through fine when installing via FTP. However when I reboot the computer the bootload starts up giving the prompt:
1: NetBSD

But when it attempts to boot NetBSD it returns an error message:
Error 3

I did some reading about the ~SError 3~T message and found that it means that the magic number: 0x55, 0xaa was not found in the partition it is attempting to boot from. I have tried a few things inluding executing the following:

installboot /dev/rwd0a /usr/mdec/bootxx_ffsv1

I read some other posts and others have had similar problem but have been able to run their systems using the boot cd to start it. I have tried to run my system from the boot cd by issuing commands like the following:

boot hd0a:
booting hd0a:netbsd
open hd0a:: No such file or directory
open hd0a:netbsd: No such file or directory

boot wd0a: 
booting wd:netbsd
open wd0a:: Device not configured
open wd0a:netbsd: Device not configured

None of this has succeded. A few other bits of possibly useful information:

If I start up the install cd again and go into a shell. I can successfully mount the drive:
mount /dev/wd0a /mnt

The one other bit of information that may help is the table for the partitions as described in the installer.

The following numbers are the sector numbers.

     Start      End        Size       Type               MP
a: |       63 | 77106014 | 77105952 | FFSv1            | / |
b: | 77106015 | 78156224 |  1050210 | swap             |   |
c: |       63 | 78156224 | 78156162 | NetBSD Partition |   |
d: |        0 | 78165359 | 78165360 | Whole Disk       |   |