Subject: Re: I need some help
To: ukr-alex <>
From: Manuel Bouyer <>
List: netbsd-users
Date: 10/27/2005 22:07:27
On Thu, Oct 27, 2005 at 02:04:27PM +0400, ukr-alex wrote:
> Hi there!
> I know that my problem was very often discussed
> But I did not find there correctly worked decision
> PROBLEM -> "No buffer space available"
> After some time of work - network interface is refuse to work
> If I try to upload to machine some files, after aproximately 60Mb
> I lose connection.

This is because for some reason the transmit path of the network
adapter stalls. This can be because of a software bug in the driver,
or hardware problem with the interface's chip.

> I has already recompile the kernel with:
>   options NMBCLUSTERS=32768
>   options NBUF=4096

This is not something that can be solved by tuning parameters.

> ...
> /netbsd: rtk0 at pci0 dev 10 function 0: Realtek 8139 10/100BaseTX
> /netbsd: rtk0: interrupting at irq 5
> /netbsd: rtk0: Ethernet address 00:02:44:77:33:d7
> /netbsd: OUI 0x000000 model 0x0000 rev 0 at rtk0 phy 7 not configured

That is most probably your problem. You need the PHY drivers in your

Manuel Bouyer <>
     NetBSD: 26 ans d'experience feront toujours la difference