Subject: I need some help
To: None <>
From: ukr-alex <>
List: netbsd-users
Date: 10/27/2005 11:05:51
Hi there!

I know that my problem was very often discussed
But I did not find there correctly worked decision

PROBLEM -> "No buffer space available"

After some time of work - network interface is refuse to work
If I try to upload to machine some files, after aproximately 60Mb
I lose connection.

named[435]: ns_forw: sendto([].53): No buffer space available
named[435]: send_msg: sendto([].1690): No buffer space available

when I try to ping someone I have the same error! (No buffer space available)

One way to make network alive is
    #ifconfig rtk0 up

I has already recompile the kernel with:
  options NMBCLUSTERS=32768
  options NBUF=4096

  net.inet.tcp.sendspace = 32768
  net.inet.tcp.recvspace = 32768
  net.inet.udp.sendspace = 9216
  net.inet.udp.recvspace = 41600

/netbsd: NetBSD 2.0
/netbsd: rtk0 at pci0 dev 10 function 0: Realtek 8139 10/100BaseTX
/netbsd: rtk0: interrupting at irq 5
/netbsd: rtk0: Ethernet address 00:02:44:77:33:d7
/netbsd: OUI 0x000000 model 0x0000 rev 0 at rtk0 phy 7 not configured

        address: 00:02:44:77:33:d7
        media: Ethernet none (none)
        inet netmask 0xfffffe00 broadcast
        inet6 fe80::202:44ff:fe77:33d7%rtk0 prefixlen 64 scopeid 0x1

I hope you'll help me. Thanks!

Best regards,