Subject: XFig --== Ghostscript (pxlmono) ==>> HP2100 LaserJet
To: None <>
From: Richard Rauch <>
List: netbsd-users
Date: 10/02/2005 14:34:45
I've had a weird problem lately (more than a few weeks, less than
3 months).  I updated the Ghostscript on my printer server, and
now when I print via "pxlmono" to my HP2100 laser, many figures
that should be outlines are filled;  It looks as if perhaps the
pxlmono driver is using filled polygons when it is asked to use

The problem doesn't happen with lj5gray, for example (a 600dpi
output format) or on local screen displays.  So it at least
somewhat relates to the choice of output driver.

I filed a bug with the Ghostscript people, but have not received
any feedback from them so do not know if they have acknowledged it
or fixed it.  (I couldn't see any evidence of it having been
reported before, but their search function on their bug database
is underwhelming, so I could easily have missed it in the thousands
of unrelated bug reports that it threw back at me when I tried to

As an example, I had a CD label using the clipart image of the
world map in the XFig database.  Instead of being a simple outline
of the continents, it prints with lots of black-filled angular
regions, now.  (Printing through the lj5gray looks okay, but the
print quality is much inferior, as lj5gray rasterizes the image
at 600dpi or so, while the printer is capable of 1200dpi; the
difference makes a big impact on some fine detail, especially if
the detail is not strictly black and white.)

The problem tends to show up in other line-art drawings, such as
a pair of semicircles that I drew with a straight arrow through
the diameter (end-to-end on the semi-circles), where half of the
enclosed circle was solid-filled black.

Text (solid-filled letters) works fine.

Has anyone else seen this?  Can you confirm with a relatively
recent build of Ghostscript?  Or have you seen such a problem
pop up perhaps a few months ago and vanish recently with one
or more drivers?

I don't know if it's a weird bug in the HP2100 firmware that
is tripped by the new Ghostscript (unlikely), a Ghostscript
bug (my favorite theory), or something that XFig is doing
weirdly when producing PostScript that is not very well-defined
(highly unlikely).

I haven't been printing much in a while, and I can route print
jobs through my "ps600" (lj5gray) virual printer instead of
"ps" (pxlmono) to drive my printer in a manner that works
a bit better, and text seems to be unaffected.  So it hasn't been
a high priority.  But the recent thread about printing brought this
to my mind again.

  "I probably don't know what I'm talking about."