Subject: Re: re : Which version
To: Johan =?iso-8859-1?Q?Wall=E9n?= <>
From: John Klos <>
List: netbsd-users
Date: 09/22/2005 01:03:37
>> Thanks to Gilbert and all the others who have responded to my attempts
>> to install NetBSD on my iBook.  Here is the current state of affairs.
>> 1) Downloaded macppccd.iso (145,472 KB) from one of the US mirrors.
>> 2) Burned it to CD.
>> 3) Got to the Open Firmware prompt and determined that the Open Firmware
>> is version 3.
>> 4) Attempted to boot the CD with a couple of the examples in the doc
>> with no success.

This should have been fixed, but I suppose it hasn't. NetBSD 2.0 and 2.0.2 
macppc cds are not bootable on either older (1.0.5) or newer (3) Open 
Firmware. I'd recommend that you partition in OS X or OS 9 with an extra 
small HFS (not plus) partiton, put ofwboot.xcf from the extracted 2.0.2 
sets (NOT from 1.6.2 - it won't work) and netbsd-INSTALL.gz from the 
2.0.2 (or 2.1-RC5 or whatever) onto that HFS partition, then boot that and 
use that to do the install.

I thought I was going crazy when I tried burning several 2.0.2 cds, tried 
several different cd and dvd drives as well as trying several different 
machines until I remembered the no booting problem with 2.0. It should be 
noted somewhere prominently on the macppc page, as I'm sure it'd save 
others time as well.

John Klos