Subject: Re: mountd fails
To: None <>
From: Jan Schaumann <>
List: netbsd-users
Date: 09/05/2005 15:16:35
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Jan Schaumann <> wrote:
> I have a problem with mountd that I simply can't figure out:
> I have a file /etc/exports consistin entirely of the following line:
> /hold   -maproot=3Droot
> When I start mountd, I get a message saying
> /hold     -maproot", line 1: Can't export /hold: Invalid argument
> /hold is a directory, under which a partition is mounted.
> What could cause mount(2) to return EINVAL on /hold ?  According to the
> manual page, EINVAL should be returned if ``The super block for the file
> system had a bad magic number or an out of range block size.''  I've
> fsck'd the filesystem (with an alternate super block to make sure), and
> still I get the same error.
> Does anybody have any ideas what's going on here?

I still have no idea what exactly was wrong, but after extracting newly
built 2.0.2 sets, mountd is now working normally again.

Since, among other things, I tried rebuilding mountd before, that wasn't
the issue.  Maybe libc?  Or libutil?  I have no idea.  But anyway,
things are back to normal.

God, that sucked.


The Internet interprets censorship as damage and routes around it.
	-- John Gilmore

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.4.1 (NetBSD)