Subject: Re: Firefox plugins
To: Matthias Scheler <>
From: Steven M. Bellovin <>
List: netbsd-users
Date: 08/20/2005 08:53:05
In message <>, Matthias Scheler writes:
>On Sat, Aug 20, 2005 at 10:04:54AM +0200, Geert Hendrickx wrote:
>> On Sat, Aug 20, 2005 at 08:45:57AM +0100, Matthias Scheler wrote:
>> > Do you use the X11 bundled with NetBSD 3.0_BETA (XFree86 4.5.0) or
>> > something else e.g. Xorg?
>> from pkgsrc (xsrc doesn't support my video card).  
>That's probably what causes your problem because I use XFree86 4.5.0.

I had had the same problem; I posted about it in May.  Here's a 
followup I posted in July:

Subject: Re: firefox-bin on -current?
From: "Steven M. Bellovin" <>
Date: Wed, 13 Jul 2005 14:02:34 -0400

In message <>, "Steven M. Bell
ovin" writes:
>In message <>, Juan RP writes:
>>On Tue, 24 May 2005 09:41:27 -0400
>>"Steven M. Bellovin" <> wrote:
>>> Is anyone successfully running firefox-bin 1.0.4 on -current?  On my 
>>> machines, I'm getting a segmentation fault.  (I need the -bin version 
>>> because I often can't print from the compiled version -- but that's a 
>>> separate problem.)
>>Running fine here:
>>NetBSD Nocturno 3.99.5 NetBSD 3.99.5 (Nocturno) #30: Mon May 23
>>11:15:04 CEST 2005  juan@Nocturno:/home/juan/build/obj/sys/arch/i386/
>>compile/Nocturno i386
>>[juan@Nocturno][~]> pkg_info|grep firefox
>>firefox-bin-1.0.4   Lightweight gecko-based web browser (binary package)
>Hmm -- I wonder if it has anything to do with the fact that I use xorg.

1.0.5 is now working for me.  I suspect that the fix had less to do 
with a new version of firefox than with the problems discussed a few 
days ago with xorg and linux emulation fonts (pkg/30690 and 30008)

		--Steven M. Bellovin,