Subject: /usr/pkg/lib/X11/fonts empty
To: None <>
From: Jon Drews <>
List: netbsd-users
Date: 06/18/2005 18:37:09
NetBSD 2.0.2_STABLE #0: Fri Jun 17 07:53:20 MDT 2005 i386

  After I recompiled and installed my userland and X sources, with My fonts could not be found. I followed the directions from
pkg_info -D fontconfig-2.3.1nb1 and ran fc-cache.
  I noticed that fc-cache tried to make cache files in
/usr/pkg/lib/X11/fonts when actually the fonts were in
/usr/X11R6/lib/X11/fonts. I solved the problem by taring up the fonts
directory in /usr/pkg/lib/X11 and replacing it with a symlink to
/usr/X11R6/lib/X11/fonts. I then ran fc-cache again and the
/usr/X11R6/lib/X11/fonts was cached. The fonts then worked.

  My question: What did I do wrong in building my X sources that the
fonts were not installed in /usr/pkg/lib/X11/fonts ? I ran (IIRC):

# ./ tools
# ./ kernel=3DNOTEBOOK
# reboot
# ./ -x -u release
# ./ install=3D/
# etcupdate

  My NetBSD laptop seems to be working OK. I am just curious why the=20
/usr/pkg/lib/X11/fonts directory was empty.

Kind regards,