Subject: Re: Compiling netbsd-2-0-2-RELEASE and netbsd-2-0
To: Liam J. Foy <>
From: Bartek Krawczyk <>
List: netbsd-users
Date: 06/10/2005 15:24:58
Liam J. Foy wrote:
> On Fri(10)/Jun/05 - , Bartek Krawczyk wrote:
>>I tried to compile netbsd-2-0-2-RELEASE from source and I get similar
>>error like with netbsd-2-0:
>>#   compile  libgroff/fatal.o
>>/usr/tools-current/bin/powerpc--netbsd-c++ -mcpu=7450 -mtune=7450
>>-maltivec -mabi=altivec -O2 -pipe -DHAVE_CONFIG_H
>>-I/usr/src/gnu/usr.bin/groff/src/include -Werror -fno-rtti
>>-fno-exceptions  -nostdinc++ -isystem-cxx
>>/usr/NetBSD-current/usr/include/g++    -nostdinc -isystem
>>/usr/NetBSD-current/usr/include -c
>>/usr/src/gnu/dist/groff/src/libs/libgroff/fatal.cpp -o fatal.o.tmp
>>/usr/src/gnu/dist/groff/src/libs/libgroff/fatal.cpp:28: internal
>>compiler error: Segmentation
>>   fault
>>Please submit a full bug report,
>>with preprocessed source if appropriate.
>>See <URL:> for instructions.
>>*** Failed target:  fatal.o
>>*** Failed command: /usr/tools-current/bin/powerpc--netbsd-c++
>>-mcpu=7450 -mtune=7450 -maltivec -mabi=altivec -O2 -pipe -DHAVE_CONFIG_H
>>-I/usr/src/gnu/usr.bin/groff/src/include -Werror -fno-rtti
>>-fno-exceptions -nostdinc++ -isystem-cxx
>>/usr/NetBSD-current/usr/include/g++ -nostdinc -isystem
>>/usr/NetBSD-current/usr/include -c
>>/usr/src/gnu/dist/groff/src/libs/libgroff/fatal.cpp -o fatal.o.tmp
>>*** Error code 1
>>Any suggestions? I tried to recompile tools but it hasn't brought any
>>effect. Has anyone managed to build NetBSD (and which version) from
>>source on macppc?
>>Bartek Krawczyk
>>GG: 2094683
> Looks like a memory problem to me. I had similar problems. My solution was to
> replace the bad memory.
It did brake in this place about 2 times, I tried to compile it again
and now it says that box.h is missing, so I get another error. Why?
Isn't netbsd-2-0-2-RELEASE supposed to be a stable release or something?
Bad memory - I haven't had any problems with that. I had Gentoo so my
iBook did much compiling and I compiled many things from pkgsrc (xorg,
mozilla etc.) so I don't think and hope it's not the problem.

Bartek Krawczyk
GG: 2094683