Subject: Re: building current
To: None <>
From: scalopus <>
List: netbsd-users
Date: 06/05/2005 09:10:38
Hi Tomoki,
  I have compiled and installed several times current without
problems with this steps that are in the documentation section:

  I hope it is helpful with you case.


On Sun, Jun 05, 2005 at 12:31:05PM +0900, Tomoki NetBSD Mailing Lists wrote:
> I have recently installed netbsd onto my laptop.  I have been trying
> to update my system to current.  But when I am compiling the userland
> the fails.  I want to make sure I am doing this correctly.
> 1) UPDATE /usr/src:  I have tried both cvs and cvsup 
> 2) compile tools: in /usr/src "./ tools"
> 3) compile kernel:  in /usr/src "./ kernel=GENERIC_LAPTOP"
> 4) install kernel:  in he compiled GENERIC_LAPTOP directory "make
> install" and restart
> I get this far fine and the booted up kernel is 3.99.5 
> 5) compile the userland:  in /usr/src "./ -U -D
> /usr/i386build/ distribution"
> 6) install compiled userland:  in /usr/src "./ -U -D
> /usr/i386build/ install=/"
> step 5 is where I run into trouble
> the compile fails.  everyday i keep updating the src and everyday
> attempt to compile, but no success yet for over a week....
> am I not doing this correct?
> TIA,
> Tomoki