Subject: Re: kernel panic from piixide or something
To: Manuel Bouyer <>
From: Petter Lindqvist <>
List: netbsd-users
Date: 03/23/2005 08:29:08
Manuel Bouyer wrote:

>On Tue, Mar 22, 2005 at 04:48:34PM +0100, Petter Lindqvist wrote:
>>Some problems here, and as the server is on remote location I couldn't 
>>see the exact console messages, but here's what's in /var/log/messages 
>>about the crash.
>>What I was doing was 'newds wd1e' then this showed up and the server died.
>>I'm not sure if it's a problem with driver, chipset or disk. So I ask 
>>here before I go yelling at the company who hires the server.
>>dmesg.boot included below crash log.
>>376192 of 376192-376319 (wd1 bn 376255; cn 373 tn 4 sn 19), retrying
>>Mar 22 14:59:05 kundserver /netbsd: piixide0 channel 1: reset failed for 
>>drive 0 drive 1
>>Mar 22 14:59:05 kundserver /netbsd: piixide0:1:0: wait timed out
>>Mar 22 14:59:05 kundserver /netbsd: wd0a: device timeout writing fsbn 
>>2048352 of 2048352-2048367 (wd0 bn 2048415; cn 2032 tn 2 sn 33), retrying
>>Mar 22 14:59:05 kundserver /netbsd: piixide0 channel 1: reset failed for 
>>drive 0 drive 1
>Hum, this is bad. The master disk on this channel has serious problems,
>and doesn't respond to anything anymore. If there is a slave drive on the
>channel, it's hung too.
>If you have any active filesystems on these drives, it may be enouth
>to almost hang the box, as any I/O will complete with large delays.
Only one disk per channel. Are you sure the disk is b0rken, or could it 
be driver/chipset problems?
If it's a problem with the disk I just request them to change the disk 
for me.
So far no file systems, it hung while doing newfs...

piixide0 at pci0 dev 31 function 2
piixide0: Intel 6300ESB Serial ATA Controller (rev. 0x02)
piixide0: bus-master DMA support present
piixide0: primary channel configured to compatibility mode
piixide0: primary channel interrupting at irq 14
atabus0 at piixide0 channel 0
piixide0: secondary channel configured to compatibility mode
piixide0: secondary channel interrupting at irq 15
atabus1 at piixide0 channel 1

I encountered one more problem yesterday, after enabling quota on one 
file system the box semi-died too. reboot didn't bite, except for 
killing my connections, but still the box answers to ping...