Subject: Re: mini iPod gets no device in NetBSD 2.0-BETA
To: Nathan J. Williams <>
From: Steven M. Bellovin <>
List: netbsd-users
Date: 03/22/2005 16:26:05
In message <>, "Nathan J. Willia
ms" writes:
>"Steven M. Bellovin" <> writes:
>> Has anyone looked into this further?  I can confirm that the problem 
>> still exists for me with a USB flash disk (PNY Attache 2.0) on a very 
>> recent -current.
>> Here's the trace:
>> umass0 at uhub2 port 1 configuration 1 interface 0
>> umass0: PNY Attache 2.0, rev 2.00/2.00, addr 2
>> umass0: using SCSI over Bulk-Only
>> scsibus0 at umass0: 2 targets, 1 lun per target
>> This machine has uhci and ehci
>Odd. My PNY Attache 2.0 (128M) works fine, on a box with ohci and
>umass0 at uhub2 port 1 configuration 1 interface 0
>umass0: Pen Drive USB DISK 20X, rev 2.00/1.00, addr 2
>umass0: using SCSI over Bulk-Only
>scsibus0 at umass0: 2 targets, 1 lun per target
>sd0 at scsibus0 target 0 lun 0: <, USB DISK 20X, PMAP> disk removable
>sd0: 119 MB, 476 cyl, 32 head, 16 sec, 512 bytes/sect x 243712 sectors
>I guess they changed chipsets?

So I'd assume, though I see this in my dmesg on the ehci/uhci -current 
machine I tried it on:

ehci0 at pci0 dev 29 function 7: Intel 82801EB/ER USB EHCI Controller (rev. 0x02)
ehci0: interrupting at ioapic0 pin 23 (irq 10)
ehci0: EHCI version 1.0
ehci0: wrong number of companions (4 != 3)
ehci0: init failed, error=13

But I think it's more likely to be the flash disk, since it's failed on 
several different NetBSD machines.  (Charles Hannum suggested that the 
EHCI problem is a BIOS bug, and that I should try deleting the return 
statement after it.  I haven't tried that yet.)

Any suggestions on what else I should try to get the flash disk 
working?  The urgent need is for a fix I can install (or retrofit) to 

		--Steve Bellovin,