Subject: Re: BIND-9.3.x crashes
To: None <>
From: None <>
List: netbsd-users
Date: 03/16/2005 13:22:33 wrote:
> Greetings, I'm having a strange problem with BIND-9.3.x dns server.
> This is happening on netbsd-2.99.16, but I also noticed it happened on 
> netbsd-2.0_STABLE
> Here is the problem:
> u10# cat /etc/rc.conf | grep named
> named=yes
> named_flags="-4 -c /etc/namedb/named.conf -t /var/chroot/named -u named"
> named_chrootdir="/var/chroot/named"
> I run 'named' daemon in a chroot jail. It starts up OK and can run for 
> days without any problems, but on random occasions it gets terminated. 
> Then if I run 'ps -ax | grep named' it shows nothing, i.e. named is not 
> running. There is nothing in the log files.
> Has anyone seen this before?

I've just realised, it could be dumping core, but /var/chroot/named was 
only writable by root. Well permissions fixed now, just have to wait and 
see if it dumps a core :-/

Looking at the mail archives, some people do mention core dumps from 
named, but nothing on how to fix it.