Subject: Re: uvisor and Treo 650
To: Nathan J. Williams <>
From: Jukka Marin <>
List: netbsd-users
Date: 03/04/2005 22:51:04
On Fri, Mar 04, 2005 at 12:53:01PM -0500, Nathan J. Williams wrote:
> > Treo 650 seems to work with uvisor (NetBSD 2.0) and jpilot and friends.
> > However, I couldn't figure out how to access the SD card on Treo from
> > NetBSD.

> The released version of pilot-link tools don't support the VFS
> interface used to access the card, but there's a new beta release
> candidate (0.12) on that does support it (about
> a month old, so active development is still happening). I haven't
> tried it on NetBSD yet, but hope to do so in the next couple of days.

Thanks, I'll give it a try.

> There's also a non-free product called "Card Export" from Softick that
> you run separately from Hotsync and that makes the PDA act as a umass
> device. The beta didn't work on my Tungsten T, but I haven't tried it
> since they released a non-beta version.

I installed the trial version.  It works with winxp, but on NetBSD, I

Mar  4 22:47:53 pyy /netbsd: umass0 at uhub4 port 2 configuration 1 interface 0
Mar  4 22:47:53 pyy /netbsd: 
Mar  4 22:47:53 pyy /netbsd: umass0: PalmOne, Inc. Palm Handheld, rev 1.00/1.00, addr 6
Mar  4 22:47:53 pyy /netbsd: umass0: using SCSI over Bulk-Only
Mar  4 22:47:58 pyy /netbsd: umass0: Get Max Lun failed: TIMEOUT
Mar  4 22:47:58 pyy /netbsd: umass0: unable to get Max Lun: TIMEOUT

and I'm unable to mount sd0 (because it's not attached, I guess ;-)

This is repeatable.