Subject: Re: Upgrade to 2.0 and passwd problems
To: Tyler <>
From: Jeremy C. Reed <>
List: netbsd-users
Date: 03/02/2005 09:27:18
On Wed, 2 Mar 2005, Tyler wrote:

> I've juste upgraded my netbsd 1.6 to 2.0.1. All seems to work excpet one
> thing :)
> First, with the user tyler I can't execute the command chsh to change my
> shell : I've got a chsh : /etc/pw00469a : Permission denied. Well I
> won't make the /etc directory writable for all or for tyler :)
> What's the problem ?
> And also I can't su with tyler (he is on the wheel group). i can type
> the password so the wheel stuff works. but it always says : wrong su

Your chsh and your su were not installed setuid.

If you unextracted from tarball, use tar -p switch.

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links