Subject: Re: linux emulation: Cannot get "tcp" protocol entry.
To: None <>
From: Jan Schaumann <>
List: netbsd-users
Date: 02/10/2005 16:25:14
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Jan Schaumann <> wrote:
> I have an application (Mathematica) that seems to be unable to connect
> to a remote host.  When it starts up, it should try to contact a network
> license server, but it fails with the error
> Cannot get "tcp" protocol entry.

Gack.  I thought I had stared at the kdump long enough, but apparently a
couple of minutes off and a new fresh look helped:

The program tried to use the NIS map protocols.byname from the ypserver.
That map was empty, though, so it failed.  Once I pushed the protocols
map from the nis server, it worked.

Confused as to why nsswitch.conf wasn't consulted, I find that my
/etc/nsswitch.conf had no entry for protocols at all.  Once I added the
entry to tell it to just use files, everything's peachy (and I don't
need to push protocols.byname from NIS).


"Drink up. The world's about to end."
"This must be Thursday. I never could get the hang of Thursdays."

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (NetBSD)