Subject: Re: external USB cases for ATA drives
To: Florian Stoehr <>
From: Denis Lagno <>
List: netbsd-users
Date: 01/03/2005 16:02:06
> > I use USB drives sometimes.  Flashes work fine.
> > But recently I've got external USB case for hard drive.
> > It turns on the drive only after plugging USB cable in.
> > And 2-3 seconds are needed to spin the drive on.
> > And it often happens that kernel recognizes only umass and
> > scsibus at umass, but not sd itself.
> > So I need to plug it off and on again in hope of finding
> > myself more fortunate.
> > Can it be because of some too restrictive timeouts in the kernel?
> Maybe this is related to the "buffer space" USB bug?
> I wrote a little program some time ago to bypass this. It will allocate,=20
> use and free a given amount of RAM.

I believe it is not direct manifestation of that bug.
I encountered that bug earlier and in that case
kernel used to issue explicit message like "no buffer memory".
(I run DEBUG+DIAGNOSTIC kernels)
That bug seems to be fixed in -current
Also, usually if I just plug drive off and on again,
kernel recognizes sd at scsibus properly.

> At least on -current, I don't think that's it.  I just bought an 
> external ATA case, too, and it takes about 30 seconds from when I turn 
> it on to when I see the console messages showing the attachment.  

When kernel recognizes sd properly it takes no more than 3 seconds.
When it is recognizes only umass and scsibus, it does not recognize
sd ever, or at least within 20 minutes.

> What version of NetBSD are you running?  If it's 2.0 and you're hitting 
> the buffer memory issue, there should be a message; I don't think that 
> that message existed in 1.6.x.  (I use fvdl's patch, so I don't see the 
> problem in any event.)

I run different recent snapshots of -current on two machines,
and both demonstrate the same behaviour with my drive.

Maybe it is just weird behaviour of the particular external case
and/or drive..