Subject: uplcom/ucom problem
To: None <>
From: Chris Ewert <>
List: netbsd-users
Date: 12/17/2004 13:27:49
I purchased a USB -> RS232 adapter recently and it works great under Windows,
but it doesn't work for me under either NetBSD 1.6 or 2.0.  The kernel
recognizes the adapter and seems to bind it to /dev/ttyU0.  I am trying to
connect to an APC unit using a cable that does something interesting with the
CTS/DTR.  The pinout of the cable I'm using is shown here:  Here is my dmesg:

uplcom0 at uhub0 port 2
uplcom0: Prolific Technology Inc. USB-Serial Controller, rev 1.10/3.00, addr 3
ucom0 at uplcom0

I added the following line to /etc/ttys and ran ttyflags -a:
ttyU0   "/usr/libexec/getty std.9600"   unknown off secure local

When I attempt to do a 'cu -2400 -l /dev/ttyU0', I am unable to communicate with
the and have it respond.  When I use a standard serial port on a computer (i.e.
tty01), everything works fine when I use cu.  I noticed kern/21043 seems to
indicate there was a bug in 1.6 with CTS/DTR, but it should be resolved in 2.0
and I tried applying the patch to my 1.6 kernel and neither worked.  Am I just
not doing something right with cu/ttyflags or is there a bug here?

Thanks in advance for any suggestions,


Chris Ewert
InfoLaunch Internet
(630) 510-9724