Subject: Re: NetBSD 2.0 problem booting after installation
To: None <>
From: Michael Smith <>
List: netbsd-users
Date: 12/14/2004 12:14:45
On Tue, 14 Dec 2004 06:45:29 -0500
"Steven M. Bellovin" <> wrote:

> This sounds similar to a problem I had with -current a few weeks ago
> -- google for 'unbootable new disk' starting 23 November.  The problem
> in my case was apparently that my BIOS and NetBSD disagreed about
> mapping sectors on such a large (160G, over the 137G limit) drive.

I have found those posts. I wondered if this was a problem of using a disk larger than 32G (I have seen mention of a limit there as well) so I tried partitioning the system to make / in wd0a < 8G. No go.

But a hint in your thread solved the problem

"Indeed -- there should probably be an option in sysinst to allow the
user to to at least the moral equivalent of formatting the disk before
installing on it, even if it is only going to do "dd if=/dev/zero
of=/dev/rwd0d count=10"."

so to be really mean I did 

dd if=/dev/zero of=/dev/rwd0d count=100

...reinstalled (it prompted me for more stuff on setting up the filesystem again) and it booted up first time. This is after four days of messing around. Most linux distros have an option to really initialise the disk before installation so presumably something had to be removed from the head of this disk.

Looking at it now it has gone to db>, probably something about a MIDI device. Job for tomorrow.

Michael Smith