Subject: NetBSD 2.0 problem booting after installation
To: None <>
From: Michael Smith <>
List: netbsd-users
Date: 12/13/2004 10:02:05
I am looking for a bit of advice on my installation of NetBSD 2.0 i386.

The disk I am installing on to has (according to the BIOS)

LBA mode
Capacity 40059 MB
Cyl 4870
Head 255
Precomp 0
Landing Zone 19176
Sector 63

When I reboot after the installation the BIOS says that there is no operating system on the disk.

If I install NetBSD with support for a second OS the boot loader reports:

Error 3

I have searched the website for solutions and I have seen recent reports of a similar problem. But it was not clear to be how I should solve this specific problem.

I have previously run Linux on this machine, with the same
configuration, without any problems.

The NetBSD installer prompted me for hard disk geometry information, and I have tried several approaches, including using the default, and entering values reported by the BIOS, but with the same result.

I used the shell utility on the installation CD to mount the installed system. I found a rescue directory with a tool which seems to install a boot loader, but I know enough about it to use it properly.

This is the newest system I have installed NetBSD on so far and I wonder if I need to pay closer attention to HD geometry to get it to work.

One interesting problem is that the primary IDE bus on this system has never worked. It was supplied to me with the main disk on the secondary IDE bus and I have used it this way with Linux installed for four years. Could this be the problem?

I have read the installation notes on the CD and experimented a bit with HD geometry.

The NetBSD distribution I am using came from an FTP mirror as i386cd.iso.

Any suggestions? Anything else I should try?

Thanks in advance.
Michael Smith