Subject: Can't get WLAN working
To: None <>
From: Philipp Klein <>
List: netbsd-users
Date: 12/09/2004 20:23:04

I'm really desparing ..
I've got a DLink DWL-G520 wireless card. Right after I installed NetBSD
2.0 I tried to set it up. It worked fine. Then I put the stuff I used to
get it working into /etc/ifconfig.ath0 and rebooted.
Now it doesn't work anymore.
I'm working on this problem since 3 hours but I can't find the mistake.
As far as I see there is just nothing wrong but I can't get it working.
Anyway, here are some of the files:

| inet netmask 0xffffff00 broadcast
| mediaopt 11g
| inet6 fe80::20d::88f:fea6:f554%ath0 prefixlen 64
| mtu 1500
| !/sbin/route add default

| # ifconfig ath0
|         ssid ebyte nwkey 0xMyKey
|         powersave off
|         adress: 00:0d:88:a6:f5:54
|         media: IEEE802.11 autoselect (DS1)
|         status: no network
|         inet netmask 0xffffff00 broadcast
|         inet6 fe80::20d::88ff:fea6:f55f%ath0 prefixlen 64 scopeid
| #

I can ping my own LAN-adress ( but every other host (no
matter if it's internet or lan) is not reachable.
Pinging another host than my own one gives me ``ping: sendto: Host is
I've got no idea what to do now. :-(

Any help is appreciated. If you need more information, just tell me.

            Philipp 'phil' Klein
   __o  Email.......:  o__
 _`\<,  GPG-ID......:  	    0xBAE21960  ,>/'_
(_)/(_) #include    <std/disclaimer.h> (_)\(_)