Subject: Re: Netboot trouble (was Re: Sparc questions)
To: None <>
From: Benjamin Walkenhorst <>
List: netbsd-users
Date: 11/20/2004 18:05:51
Hello, wrote:

>>I now have set up rarpd, tftpd and nfs on my home server and tried
>>booting the
>>Sparc over network for the first time - unfortunately, OpenBoot does not
>>the twisted pair cable correctly and gets a rarp timeout. I started the
>>rarp daemon
>>on my server in debug mode to make sure - no packet arrives...
>>When I boot the system installed on the harddrive, it does detect the
>>cable and gets
>>a dhcp lease, though. What am I doing wrong?
>Odd.. It usually should detect which media you're using.
>Instead of 'boot net' give 'boot net-tpe' a try.

I tried, but it didn't help... =(

>Did you name the TFTP image on the server with the correct ethernet
According to the Diskless-Boot-HOWTO the file has to be named according 
the IP-address of the client...
But your remark made look up the logs on the server - I should have done 
so from the beginning.
The boot image's name was missing a '0'...

Now that works, but the NFS part isn't working yet...
But that would be different thread. =)

Thanks to everyone,