Subject: Re: sis964 and lost interrupt
To: Manuel Bouyer <>
From: Jorgen Lundman <>
List: netbsd-users
Date: 10/17/2004 20:33:54
Naturally, I probably was not clear. Tried NetBSD-2.0RC install and GENERIC. 
They didn't see it at all. We tried to patch around it like it was a 963 but 
that did not go so well. We then fetched the -current kernel, to try. Which 
attaches (eventually, takes about 10 minutes to boot) but fires away with the 
"lost interrupt" problem. Then we went to try disabling everything. Only tried 
MP kernel to make sure the system is otherwise fine.

Currently it is UP kernel, with siside0 only (so that it doesn't attach siside1) 
so we can use it until there is a fix for it.


Manuel Bouyer wrote:
> On Sun, Oct 17, 2004 at 01:07:48PM +0900, Jorgen Lundman wrote:
>>NetBSD-2.0RC4 and current (20041015). asus p4s800d with latest v1011 
>>bios. The first PATA chains appear good, but the SATA chain gets "lost 
>>interrupt". The dmesg is attached.
>>I have been searching archives, and someone suggested perhaps they could 
>>not do UDMA at 512 sized blocks, so I forced PIO mode (flags 0x0ffc) but 
>>that made no difference. Attempted to join the drives as a raid, and 
>>have the unit see the raid instead of wd4 and wd5. No difference. 
>>Nothing else is on irq 11.
>>Also tried disabling anything we don't need, USB and that. Someone else 
>>had success turning on debug prints, but that made no difference to us.
>>Without those two drives plugged in it works great. Even with MP build.
>>siside.c latest we've tried is v1.13
> Did you try with a UP kernel ?

Jorgen Lundman       | <>
Unix Administrator   | +81 (0)3 -5456-2687 ext 1017 (work)
Shibuya-ku, Tokyo    | +81 (0)90-5578-8500          (cell)
Japan                | +81 (0)3 -3375-1767          (home)