Subject: Audio recording through the microphone
To: None <>
From: Julio M. Merino Vidal <>
List: netbsd-users
Date: 10/08/2004 21:09:36
Hi all,

I'm trying to record audio through the microphone, but all I get is noise.
First of all, I tried with audacity and gnome-sound-recorder, with no good
results (i.e., a constant noise and no signs of the real input).

Then I used mixerctl to change several variables: inputs.mic=255,
inputs.mic.mute=off, inputs.mic.preamp=on, record.source=mic,
record.volume=192,192, record.volume.mute=off.  After this, if I talk to
the microphone, I can listen myself through the speakers.  But still,
trying to record anything results in the same strident noise.

I also tried to disable all unused inputs (lowering their volume and
setting mute=on on them).  I couldn't disable some, like
or inputs.speaker (probably because my card has no such things?).

So I tried it the simplest way: cat /dev/audio >/tmp/  Again,
the same noise!

Well, at last, just to say that I have an auvia card:

auvia0 at pci0 dev 17 function 5: VIA Technologies VT8235 AC'97 Audio (rev 0x50)
auvia0: interrupting at ioapic0 pin 22 (irq 7)
auvia0: ac97: Analog Devices AD1980 codec; headphone, 20 bit DAC, no 3D stereo
auvia0: ac97: ext id 3c7<AMAP,LDAC,SDAC,CDAC,SPDIF,DRA,VRA>
audio0 at auvia0: full duplex, mmap, independent

Am I doing something wrong?  May it be a bug in the driver?


PS: The final goal is to get Skype working.
PPS: Please CC me all replies.

Julio M. Merino Vidal <>
The NetBSD Project -