Subject: Re: Need to run a .jar file
To: None <>
From: Steven M. Bellovin <>
List: netbsd-users
Date: 07/27/2004 16:19:32
In message <>, "Steven M. B
ellovin" writes:

>>I just removed it and installed lang/sun-jdk14. Now the -jar option is 
>>there, but now whenever I try to run it (for anything other than just doing 
>>"java -?"), I get the following error:
>>   Java HotSpot(TM) Client VM warning: Can't detect initial thread stack 
>>   Error occurred during initialization of VM
>>   Could not reserve enough space for object heap
>>I'm running a more-or-less GENERIC -current kernel built from sources about 
>>10 days ago (userland is the July 15 -current snapshot from 
>> This is running in a VMWare client VM with 256MB of 
>>memory allocated to it. Is there some option I need to put in my kernel 
>>config? A missing library? 
>'ulimit -d 262144' will get rid of the "Could not reserve enough space" 
>problem.  The message about the thread stack is a warning; I don't know 
>how to make it go away, but it doesn't seem to hurt, at least in the 
>few cases I've tried lately.

Thinking more about the thread stack message, I realized that I hadn't 
tried any threaded programs...  I did google for the phrase, and found 
this note:

I have /proc mounted; here's my fstab entry:

	procfs          /proc   procfs  rw,linux

but I'm still seeing the message.  Any suggestions?

		--Steve Bellovin,