Subject: Re: home end keys do not work
To: None <>
From: Karsten Kruse <>
List: netbsd-users
Date: 07/15/2004 16:53:34

> > The tilde is part of the sequence sent by the key! You need to 
> > include it in the binding sequence! I told you those keys send CSI 1 
> > ~ and CSI 4 ~ , not just CSI 1 and CSI 4

> i tried even this, but the result is every time the same. bind doesn't 
> display the tilde at the end of the sequence i.e.
>   bind '^[[4~'=end-of-line
> is then reported by bind as
>   ^X4 = end-of-line
> with the "end key" behaviour that it moves the cursor to the end and 
> prints tilde :(

> i also tried to put backslash in front of the tilde, but nothing 
> happened. am i doing something wrong here? i'm absolutely clueless now 
> :(

I don't think so. The Problem is that ksh can't bind sequences with 
more than two chars. So i asked google and found this:

What i have now in my kshrc is this:

  # Bind POS1, END and DEL keys
  bind '^XH'=beginning-of-line      # POS1/HOME
  bind '^XF'=end-of-line            # END
  bind '^[[3'=prefix-2              # DEL
  bind '^[[3~'=delete-char-forward  # DEL

That works for me when TERM is xterm (HOME/END will not work when TERM 
is screen).


         Homepage, Mac68k, A/UX-Links und Shorties:
   ()    Linux/NetBSD-Anleitungen, Forum  und Chat:
  _/\_   Slowly and surely the unix crept up on the Nintendo user ...