Subject: Re: home end keys do not work
To: Lubos Vrbka <>
From: Florian Stoehr <>
List: netbsd-users
Date: 07/13/2004 16:17:07
On Tue, 13 Jul 2004, Lubos Vrbka wrote:

> hi,
> thanks for the hint about autolearning of keys in midnight commander. it
> works fine (however if it is "configured" for mc in xterm it doesn't
> work in mc on console)...
> > While learning how to use emacs for editing is always a good thing,  ;-)
> > you might find these commands (or something very similar) to be useful
> > additions to your ~/.profile (or ~/.kshrc or whatever you point $ENV at)
> >
> > 	bind '^XH'=beginning-of-line
> > 	bind '^XF'=end-of-line
> i tried these but they doesn't work. bind registers them, but they only
> produce the tilde character again. if i press ctrl-x and then shift-h,
> the cursor goes where it should but not when home/end are pressed. it is
> strange for me. i tried in xterm, aterm (TERM=xterm), on console
> (TERM=vt220), but no luck... what else can be wrong?
> in hexdump, these keys produce ^]]1 and ^]]4 (in x-windows, on console
> they produce ^]]7 and ^]]8), so i tried to use these for bind. they move
> the cursor to the desired place, but they still print out the tilde
> character...
> is it possible to find the codes corresponding to keys somewhere? (i.e.
> that ^XH is home, ...)?
> regards,
> --
> Lubos
> _@_"

On console, try setting your terminal to "screen" instead of "vt220".