Subject: Re: 2.0beta, ulpt, HP LJ1200
To: Marc Recht <>
From: Jukka Marin <>
List: netbsd-users
Date: 06/01/2004 23:38:01
On Tue, Jun 01, 2004 at 10:32:15PM +0200, Marc Recht wrote:
> > It seems I'm having lots of trouble with NetBSD 2.0beta.  The most
> > recent problem discovered is that I can no longer print to my HP
> > LJ1200 laser via USB.  Under 1.6, I used /dev/ulpn1.  Under 2.0beta,
> > all data sent to that device just disappeares - the printer doesn't
> > even blink its led.  I also tried /dev/ulpt1 which produces the same
> > result with an added delay.
> I've just checked and have the same problem with by HP LaserJet 1300.
> I'm absolutly sure that it worked with the same configuration beginning
> of this year...

I changed ulpt.c (changed that #if 0 to #if 1) and was able to print.
After the job completed, the system paniced.  I built a kernel with
ddb and -g and now I can't repeat the panic (of course).  From the first
panic, I saw the panic occurred in usb_transfer_complete().

> Please open a PR for it.

Ok, I will.. wish I could repeat the panic (now I'll be afraid to print
anything in the fear of the Attack of the Panic).