Subject: Re: problems booting (Error 3) after drive swap
To: <>
From: David Laight <>
List: netbsd-users
Date: 05/21/2004 19:09:16
On Fri, May 21, 2004 at 08:09:51AM -0400, Steve Bellovin wrote:
> I'm trying to install a new disk for my laptop.  I copied the contents of
> the old one, but when I try to boot I get "Error 3" when I select the
> NetBSD partition.  

"Error 3" means that the magic number (0x55, 0xaa) wasn't found in the
first sector of the NetBSD mbr partition.

> Since I get a partition selector, and since I can boot the Win2k
> slice, I assume that the mbr boot is fine.  I tried running
> 	installboot /dev/rwd0a /usr/mdec/bootxx_ffsv1
> from the utility menu of a -current installation CD I have; I still get
> the same error.

Does the 'a' partition start at the beginning of the NetBSD partition?
That is where the bootxx_ffsv1 file has to be written to.
(The copy is nothing clever, but must avoid stomping over the label
in the 2nd sector of the partition.)


David Laight: