Subject: Re: NetBSD 2.0 backward compatibility problems
To: None <>
From: Parkes, Lloyd <>
List: netbsd-users
Date: 05/19/2004 10:08:27
> There are fixes for parsing problems on the way. And besides that I 
> don't
> think that enforcing a stricter syntax is a bad thing.,

I'm more concerned about the lack of documentation than anything. I've 
finally found the INSTALL doco (where I should have looked for it in 
the first place) and it still mostly refers to updating from 1.5 to 

> That sounds like your kernel configuration doesn't include the
> "COMPAT_16" option which is required to run pre 2.0 binaries.

I'm running a GENERIC kernel at the moment. I've just checked and it 
does have COMPAT_16 set. I'll have to dig some more. I don't recall the 
core dump saying anything about an illegal system call, so I assumed 
that the compat stuff that was in place wasn't working.

When I've got something concrete to report I'll raise some PRs.

Lloyd Parkes