Subject: Re: NetBSD 2.0 backward compatibility problems
To: None <>
From: Matthias Scheler <>
List: netbsd-users
Date: 05/18/2004 19:11:01
In article <>,
> 1) With the ipfilter upgrade, ipf(8) is now much stricter about 
> enforcing correct syntax for ipf.conf. It no longer silently adds the 
> required srcdst field.

There are fixes for parsing problems on the way. And besides that I don't
think that enforcing a stricter syntax is a bad thing.,

> 2) Apache broke big time. It always core dumped in _sys___sigsuspend14 
> which was being called from my old package of pth-2. I suspect that 
> this bit of backward compatibility isn't quite right

That sounds like your kernel configuration doesn't include the
"COMPAT_16" option which is required to run pre 2.0 binaries.

	Kind regards

Matthias Scheler