Subject: Re: 3ware escalade BIOS & PC weasel through a xterm
To: Herb Peyerl <>
From: john heasley <>
List: netbsd-users
Date: 12/12/2003 20:54:04
Fri, Dec 12, 2003 at 01:37:09PM -0700, Herb Peyerl:
> john heasley <>  wrote:
>  > I am having trouble with the display of a 3ware escalade card's BIOS
>  > configuration via a xterm.  There is none; it re-paints the screen
>  > and tab moves between fields, but nothing is visible.
>  >   
>  > I have tried the suggested xterm Xresources and the vga font found
>  > on the PC weasel support pages.  Same result.
>  >   
>  > Wondering if anyone has suggestions or experience here.  TIA.
> This seems more like a PC Weasel tech support question. Fortunately, I
> am also that person.  However, I'm still Cc'ing to the NetBSD 
> list in case you're posting here by way of saying that you've tried
> it on some other platform and it works fine but really only doesn't
> work on NetBSD in an xterm.

heh.  I thought that the NetBSD (www, anoncvs, etc) machines might
have a similar setup - and hoped that the sysadmins might speak up.
The only other platform I have is Solaris, on which I've tried xterm
and CDE terminal.  I have also tried the console (no X) on a netbsd

I have also tried Tyan's "remote management" via the serial line.  Same

> Newer versions of 3ware Escalades render text in a graphical mode
> so as to fit more data on the screen.  A downrev of the firmware
> will resolve that issue, if that's what you're seeing.

it claims the following
3ware ATA RAID Controller : Escalade  7506-8
BIOS: BE7X  Firmware: FE7X
and the 3ware page lists 7.6.3 as the latest.  It does appear to be
purely graphic output (via script and tip), though no text (such as
the disk identities) appear in that output.

> So can you confirm that it works fine outside of NetBSD (using 
> a regular terminal emulator?  Have you captured any data to ensure
> that what you're seeing is not just a 'foreground=background' 
> problem?

I do not believe that it is a color issue; i've tried several variations.
Other than xterm, CDE terminal, and the console, I'm not sure what else
to try.