Subject: Re: 3ware escalade BIOS & PC weasel through a xterm
To: john heasley <>
From: Herb Peyerl <>
List: netbsd-users
Date: 12/12/2003 13:37:09
john heasley <>  wrote:
 > I am having trouble with the display of a 3ware escalade card's BIOS
 > configuration via a xterm.  There is none; it re-paints the screen
 > and tab moves between fields, but nothing is visible.
 > I have tried the suggested xterm Xresources and the vga font found
 > on the PC weasel support pages.  Same result.
 > Wondering if anyone has suggestions or experience here.  TIA.

This seems more like a PC Weasel tech support question. Fortunately, I
am also that person.  However, I'm still Cc'ing to the NetBSD 
list in case you're posting here by way of saying that you've tried
it on some other platform and it works fine but really only doesn't
work on NetBSD in an xterm.

Newer versions of 3ware Escalades render text in a graphical mode
so as to fit more data on the screen.  A downrev of the firmware
will resolve that issue, if that's what you're seeing.

So can you confirm that it works fine outside of NetBSD (using 
a regular terminal emulator?  Have you captured any data to ensure
that what you're seeing is not just a 'foreground=background'