Subject: Re: pkgsrc dependency problem
To: Thomas devreese <>
From: Gabor Nyeki <>
List: netbsd-users
Date: 12/07/2003 17:21:21
On Sun, 7 Dec 2003, Thomas devreese wrote:

thomas> I want to install psi from the latest pkgsrc.
thomas> After a while:
thomas> ===> Installing for glu-5.0.2nb3
thomas> ===>  glu-5.0.2 is already installed - perhaps an older version?
thomas> *** If so, you may use either of:
thomas> ***  - "pkg_delete glu-5.0.2" and "make reinstall" to upgrade properly
thomas> ***  - "make update" to rebuild the package and all of its dependencies
thomas> ***  - "make replace" to replace only the package without re-linking
thomas> ***    dependencies, risking various problems.
thomas> *** Error code 1
thomas> If I do pkg_delete glu-5.0.2, it says that it's needed by a ton of other
thomas> applications like kdebase-3.1.4.
thomas> make update will update almost all installed programs, including kde. I'd
thomas> rather not do that to install a simple chat program.
thomas> make replace will very likely screw a few programs dependent on it, so
thomas> that's not an alternative.

  pkg_delete -f glu  should work.

NetBSD: ``divide et impera''