Subject: problem with mount_ext2fs on sparc64
To: None <>
From: Anand Buddhdev <>
List: netbsd-users
Date: 10/22/2003 13:03:48
Hi everyone,

I'm very new to NetBSD. Just installed version 1.6.1 (sparc64) yesterday
on a Sun E250 box. I was quite impressed by the simple but powerful
install system. And in just a few minutes, I had a system up and
running. I am ever more impressed with the rc system, and the pkgsrc

Now, I have a small problem. I have 2 disks in this box (sd0 and sd1). I
installed NetBSD on sd0. sd1 had a single partition of type linux ext2,
which I didn't touch during the installation. It has some data which I
want to recover.

After installation, I tried to mount this partition, but I was not able
to. I did:

mount -t ext2fs /dev/sd1a /mnt

and I got:

mount_ext2fs: /dev/sd1a on /mnt: Operation not supported by device

I used disklabel to see what was wrong, and I saw that the partition was
showing up as type 4.2BSD. I used the interactive mode of disklabel to
set the partition to type "Linux Ext2". And then I tried to mount it
again, and I get the same error message. But I don't understand what it
means. Does anyone know what it means?

Anand Buddhdev