Subject: Re: can't get dhclient to start during boot
To: None <>
From: henry nelson <>
List: netbsd-users
Date: 09/23/2003 13:10:39
On Mon, Sep 22, 2003 at 10:39:58PM +0200, Manuel Bouyer wrote:
> On Mon, Sep 22, 2003 at 09:47:08AM +0900, henry nelson wrote:
> > I replaced /sbin/dhclient with the latest from ISC, but now it fails to
> > start up during boot.  It dies with the message: '/sbin/dhclient: 1:
> > Syntax error: "(" unexpected'.  Works fine from the command line after
> > boot-up has finished.
> Maybe it's started before /usr is mounted, and so needs to be statically
> linked ?

I saw this kind of response (static vs shared) when I ran a google search
on the error message.  I looked at the Makefile for dhclient, and I couldn't
see anywhere that it isn't linked statically, i.e., I think it IS statically

Maybe the gurus can give me some ideas on how to debug this problem.  For
example, what command(s) could I use to verify how the dhclient binary was
linked?  If it does happen to be linked to shared libraries, how should I
go about modifying the Makefile so that it will be statically linked?
(The configure script doesn't take any arguments except machine type.)

Is there some way I can boot up step-by-step so I can discover exactly
what script this message is emanating from?

One more thing I'm unsure about is my partitioning of the disk.  I have
/var on a separate slice from /.  This worked fine in 1.5.2, but maybe
something is different in 1.6.1?  I do have /var listed in mount_critical

Anyway, thanks for any help.

henry nelson