Subject: Re: sysinst won't mount an ext2 file system?
To: Art Lemasters <>
From: Lubomir Sedlacik <>
List: netbsd-users
Date: 04/14/2003 08:35:32
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


On Sun, Apr 13, 2003 at 11:50:18PM -0600, Art Lemasters wrote:
> I had tried ext2fs but just now found out why sysinst was telling me
> that it couldn't mount the ext2fs file system.  Each time running
> sysinst, I made an error on the first try (e.g., entering "wd0"
> without an alpha designator for the partition).  I finally told
> sysinst to try anyway (3rd option, IIRC), regardless of the error
> message saying it was unable to mount.
> After choosing the option to try mounting anyway, sysinst told me that
> the necessary compressed install files weren't in the ext2fs drive
> directory, so it must have mounted.  sysinst was only repeating the
> error message that it was unable to mount from earlier errors on my
> part.

if it failed, then there is nothing to look at.  "try mounting anyway"
will just ignore the error in mounting process, nothing else.

> So it was unable to find the tgz files.  This is embarrassing.  Yes,
> they were downloaded with a browser (Mozilla, with <shift-left mouse
> click>), but it worked for the floppy install files.

i don't really think that's the problem.  you can try to extract them
with e.g. 'tar tvzf' to see if they are ok.

> Thank you for the certainty on sysinst looking for "ext2fs" instead of
> "ext2," Lubomir.  Your help prompted me to try again and to check the
> .tgz files again.

ext2fs is the name NetBSD uses for Linux Ext2 file system.

> You asked what I did to try to mount the ext2fs drive from the shell
> that comes with sysinst.  I did
> mount -t ext2fs /dev/wd0f /mnt
> and
> mount -t ext2fs /dev/wd0f /mnt

these two lines are the same, are you sure it's not a typo?

> The error message returned was "device not configured" or something
> meaning the same.

do you have /dev/wd0f?  did you check the disk with mbrlabel to see the
correct slice?

i would suggest you to do it this way, if you are not sure about the
whole process:

- exit sysinst after boot or start new shell
- run 'mbrlabel wd0' to see what part of your disk is ext2fs slice
- mount the file system manually
- start sysinst again (or exist the new shell) and select "already
  mounted directory" as source of installation sets, e.g. /mnt2
  (be careful, because /mnt is used by the installation process as the
  target filesystem, iirc, /mnt2 is used for source of sets)
- make sure you have the sets in correct directory tree so sysinst can
  find them (i don't recall if you can change it or just had to follow
  the convention--i don't use sysinst myself at all)


-- Lubomir Sedlacik <>                   --
--                  <>                   --

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.1 (NetBSD)