Subject: Re: sysinst won't mount an ext2 file system?
To: netbsd-users <netbsd-users@NetBSD.ORG>
From: Art Lemasters <>
List: netbsd-users
Date: 04/13/2003 23:50:18
   I had tried ext2fs but just now found out why sysinst was
telling me that it couldn't mount the ext2fs file system.
Each time running sysinst, I made an error on the first try
(e.g., entering "wd0" without an alpha designator for the
partition).  I finally told sysinst to try anyway (3rd option,
IIRC), regardless of the error message saying it was unable
to mount.

   After choosing the option to try mounting anyway, sysinst
told me that the necessary compressed install files weren't
in the ext2fs drive directory, so it must have mounted.  sysinst
was only repeating the error message that it was unable to mount
from earlier errors on my part.

   So it was unable to find the tgz files.  This is embarrassing.
Yes, they were downloaded with a browser (Mozilla, with
<shift-left mouse click>), but it worked for the floppy install

   I'll download the files with a command line ftp package and
try it again.  Thank you for the certainty on sysinst looking
for "ext2fs" instead of "ext2," Lubomir.  Your help prompted me
to try again and to check the .tgz files again.

   You asked what I did to try to mount the ext2fs drive from
the shell that comes with sysinst.  I did

mount -t ext2fs /dev/wd0f /mnt


mount -t ext2fs /dev/wd0f /mnt

The error message returned was "device not configured" or
something meaning the same.

   Thanks again.  I'll get it installed and will learn.

Art, the redundant newbie

Lubomir Sedlacik wrote:
> hi,
> On Sun, Apr 13, 2003 at 11:06:10PM -0600, Art Lemasters wrote:
>>In sysinst, to mount the Linux drive (wd0), I entered the device as
>>wd0, and then wd0f in the next try (just in case it needed the
>>partition designator).  ext2 was entered as the file system.
> it should be ext2fs, not ext2.
>>I entered the proper directory for the NetBSD install files on the
>>GNU/Linux drive.
>>sysinst told me that it couldn't mount the drive.  I went to the shell
>>offered in sysinst and tried to manually mount the GNU/Linux drive.
> what exactly did you do to mount it manually?
>>Will I have to compile a kernel in Linux again to enable it to mount a
>>NetBSD system and copy the files to it that way?
> INSTALL kernel already has support for ext2fs, you don't need to compile
> new kernel.
> regards,