Subject: uvm crashes
To: None <>
From: None <>
List: netbsd-users
Date: 04/02/2003 15:18:57
Hello list,

I have some general questions about crashes related to uvm.  I'm trying to
install NetBSD and I've been getting a lot of uvm_fault related crashes. 
Sometimes these happen while I'm in sysinst and sometimes (actually most
of the time) they happen when I untar pkgsrc.  This particular machine
worked fine with 1.6G for a while, but now it's acting really funny.  I
tried installing 1.6P, 1.6, and 1.6.1_RC3 but had the same results (I'm
not so sure about 1.6, because it crashed during the install process).

I tried softdeps with 1.6P, because my dell has been performing very
stable.  When I enabled softdeps on this machine, it crashed while I was
untar'ing pkgsrc. The ddb output had something related to
softdeps_write_finish or something similar, and uvm.

I don't have a trace from ddb, but pretty much all crashes were related to
UVM (I dont know how useful that is, probably not very).  The only thing
that changed in the machine is the network card.  When I had new netgear
(sip driver) cards in this machine, it ran rock solid on 1.6G.  I even
used it as a NAT box for a while, and never saw a crash.

Now I use a different NIC.  I tried out several NICs, mostly rtk, ne and
tlp.  I'm aware that those realtek cards are crappy, but those are the
only ones I have right now.  On one of the ne cards I got a message about
the NIC memory being corrupted, but it still worked.  The tlp ones gave a
lot of 'buffer underrun' or 'stray interrupt' errors, but still worked. 
The rtk cards worked too without errors, but in the end NetBSD crashed on
all of those cards.

That's the only difference I can think of, between the time the machine
worked fine and now.  The ethernet is also 10baseT now; it used to be
100baseTX, I don't know how much that matters though.  The box uses a Asus
A7V333 motherboard, Athlon XP 2400 and 512MB of RAM.  There's only one PCI
card in the box, which is the NIC.

So, I'm wondering, is it possible for the NICs to cause these uvm crashes?
 I never had sysinst crash on me before.  Could it be that my memory stick
went bad?  I haven't touched that was working fine before I
reinstalled.  Is there anything else I should look for?

Any help is much appreciated