Subject: Re: Invalid partition table on Dell
To: None <>
From: None <>
List: netbsd-users
Date: 04/01/2003 15:58:08

I apologize for not doing my own research first.  I've fixed the problem. 
If anyone wants to know how I fixed it, here's how.  I searched google
(something I should have done before posting) and found this e-mail:

I did exactly what was told in there; I moved the partition to '0' using
the same information as '3'.  After that, I used fdisk -a to make 0
active.  Now it works like a charm.  I also noticed that someone sent a PR
for this:

It seems like 'normal' Dell workstations are also affected by this problem.

> Also, I forgot to mention this.  When I boot from the cd, and do "boot
> hd0a:netbsd" it works fine, and boots into the OS.
>> Hello,
>> I just got a brand new Dell Precision Workstation 340 Series (2.5Ghz,
>> 512MB, 80GB drive).  Dell ships these things with Redhat if you choose
>> to.
>>  I wiped off Redhat as soon as I got the machine and installed NetBSD
>> 1.6
>> on it.  After I rebooted, I get:
>> Invalid partition table
>> And it doesnt boot up.  I've tried using 'normal
>> bootblocks' and 'serial bootblocks' but no difference; same error
>> message.  I went into the BIOS and made sure the hdd is the first boot
>> device.  But that didn't help, I can't explain this... I was so
>> excited too.  This is a brand new computer...has this happened to
>> someone else?  Does anyone know how to fix this?  I'd appreciate any
>> help I can get.
>> Thanks