Subject: Re: rebuilding bonobo?
To: Johnny Lam <>
From: Steven M. Bellovin <>
List: netbsd-users
Date: 12/22/2002 17:20:44
In message <20021222185337.GB18661@auron.sgtc>, Johnny Lam writes:
>On Sun, Dec 22, 2002 at 01:47:51PM -0500, Steven M. Bellovin wrote:
>> In message <20021222183642.GA18661@auron.sgtc>, Johnny Lam writes:
>> >On Sun, Dec 22, 2002 at 08:47:01AM -0500, Steven M. Bellovin wrote:
>> >> 
>> >> Hmm -- I tried deleting freetype2.  Nothing depended on it, but I still 
>> >> can't build bonobo.  (I still have freetype-lib installed, but several 
>> >> other packages depend on it, and I really need those and don't want to 
>> >> risk their unavailability if I have build problems.)
>> >
>> >Can you grep /usr/pkg/lib/*.la for ""?  It's likely that
>> >one of the installed libtool archives references, which is
>> >causing your breakage even if freetype2 is uninstalled.  I also notice
>> >that Bill Sommerfield submitted a PR today with the same complaint.
>> >
>> >	Cheers,
>> >
>> >	-- Johnny Lam <>
>> >
>> Ah -- /usr/pkg/lib/ has it.
>> So rebuilding it should solve my problem?
>For now, you can solve your problem by ensuring that graphics/freetype2
>is not installed, then rebuilding print/gnome-print, then rebuilding

That worked -- my thanks!  (And I await your fix -- anything that gets 
rid of the more obscure failure modes of pkgsrc is a good thing.)

		--Steve Bellovin, (me) (2nd edition of "Firewalls" book)